WLAN/Wifi-Verbindung zum Mission Planner

midi_7

Member
Beiträge
13
hallo Reinhard,

wiestd du ungefähr in welchem thred was über den
Geekcreit® DT-06 für den Mantek geschrieben wurde?
ich kann es in dem alten Forum nicht mehr finden.
viele Grüße Michael
 
Zuletzt bearbeitet von einem Moderator:

Reinhard

Administrator
Teammitglied
Beiträge
312
In Beitrag #243 … Ich kopiere mal meinen Text zur Einstellung zu einer Frage von Andreas:

+++

Ok, gucken wir mal ...

DT06:
Module / Serial: 57600 Baud, 8, None, 1, 30ms
Module / Wifi: Soft AP Settings: Enable, SoftAP IP: 192.168.4.1 SoftAP netmask: 255.255.255.0 SoftAP gateway: 192.168.4.1, restliche Settings: Disable
Module / Networks: ganz oben UDP Server auswählen, UDP Server: 14550, UDP Broadcasting 192.168.1.255 mit Port 14550

Save und Restart (unter More). Ich hab Port 14550 anstatt 9000 eingestellt, weil 14550 Standard im Mission Planner ist.

ArduPlane:
Ich hab UART6 genommen, funktioniert aber auch mit anderen freien:
FPL SERIAL6_BAUD: 57, SERIAL6_PROTOCOL: 2

Mission Planner:
UDP auswählen, Port 14550, Connect

QGroundControl:
Comm Links wählen, mit Add neuen Eintrag anlegen
Name: F405, Type: UDP, Listening Port: 14550, Target Hosts: 192.168.4.1 und Add klicken, Ok zum speichern

Dann wie üblich PC oder Smartphone via WLAN mit dem Adapter verbinden, Mission Planner oder QGC starten.

Wenn es jetzt nicht klappt, bitte Screenshots vom WLAN-Adapter.

+++

Wenn es Dir um eine WLAN-Verbindung zur Einstellung geht, gibt es noch 'ne bessere Möglichkeit:

Du besorgst Dir das Adafruit Huzzah ESP8266 Board wie hier beschrieben und spielst die Software drauf wie weiter unten erläutert.

Das Board gibt es in/aus D von Amazon.de: https://www.amazon.de/Adafruit-Huzzah-ESP8266-Breakout-ADA2471/dp/B0131V0WYI


P.S.: ich hab Fettschrift und Schriftgröße in Deinem Beitrag zurückgesetzt. Die normale Schriftgröße reicht hier wohl aus ...
 

Jenny

Well-known member
Beiträge
107
Hallo Reinhard,

wieso ist das Adafruit Huzzah ESP8266 Breakout besser als das Geekcreit DT-06?

Schöne Grüße
Jenny
 

Reinhard

Administrator
Teammitglied
Beiträge
312
Das DT-06 arbeitet mit 3,3V Pegeln, dass Huzzah ist 5V tolerant, also ein bisschen universeller.

Bei beiden braucht man übrigens einen FTDI-Adapter zur Programmierung.

Was auch gut funktioniert ist das Amica Modul V2 ESP8266. Das hat gleich den FTDI-Adapter integriert, hier mit einen normalen Micro USB Anschluß.

Von oben nach unten: DT-06, Huzzah, Amica:
 

Anhänge

  • 00366D92-ABA1-49F2-8B17-4AAD21216450.jpeg
    00366D92-ABA1-49F2-8B17-4AAD21216450.jpeg
    129,5 KB · Aufrufe: 11
Zuletzt bearbeitet:

Reinhard

Administrator
Teammitglied
Beiträge
312
Noch ein paar Details:

Das DT-06 hat eine Software schon ab Werk drauf. Die Einstellungen hab ich in Beitrag #2 im oberen Teil beschrieben.

Huzzah und Amica hingegen müssen erst programmiert werden und zwar mit der Software, die im unteren Teil von Beitrag #2 verlinkt ist. Ist kein Hexenwerk und dauert höchstens 30 Sekunden, muss aber halt gemacht werden. Der Vorteil davon ist, das die Software speziell auf Mavlink-Daten ausgelegt und das WLAN-Handling flexibler ist (automatische Umschaltung zwischen AP- und STA-Modus).
 

Jenny

Well-known member
Beiträge
107
Vielen Dank, Reinhard!

Wie das mit der automatischen AP/STA Umschaltung funktioniert, ist mir nicht klar. Mit meinem DT-06 muss ich jedenfalls erst mit Windows eine Netzwerkverbindung herstellen, bevor ich mit Mission Planner eine Verbindung aufbauen kann. Leider geht dabei immer die Verbindung zu meinem Internetrouter verloren, ich habe also nur entweder Mission Planner oder Internetzugang, und ich weiß nicht ob man das irgendwie besser machen kann.

Ansonsten funktioniert das DT-06 bestens, außer dass die Vergabe eines Passworts für den AP nicht zu funktionieren scheint. Das Ding ist unter Windows immer als "offenes Netzwerk" sichtbar. Allerdings ist es wohl eher unwahrscheinlich, dass sich jemand auf meinen Matek F405-Wing einhackt und dort schlimme Schadsoftware installiert. :)

Schöne Grüße
Jenny
 

Reinhard

Administrator
Teammitglied
Beiträge
312
Wie das mit der automatischen AP/STA Umschaltung funktioniert, ist mir nicht klar.
In der Konfiguration werden für AP und STA zwei Profile angelegt. Im Normalfall wird AP benutzt und Du muss mit Smartphone, Tablet oder PC eine Verbindung zum AP "Ardupilot" herstellen, bevor Mission Planner oder QGroundControl benutzt werden können.

Bei STA verbinden sich Huzzah oder Amica automatisch mit einem anderen AP. Das kann der heimische Router sein, oder in meinem Fall ein externer Accesspoint bzw. WLAN-Router. Ich verwende hier eine Netgear AirCard. Im Feld schalte ich einfach die AirCard zuerst ein. Smartphone oder Tablet verbinden sich automatisch damit, ebenso wie das Huzzah nach dem Einschalten. Ich hab dann ein WLAN-Netz, in dem alle Geräte hängen und gleichzeitig Internet-Zugang, um bspw. Karten mit dem Mission Planner laden zu können.
 

Jenny

Well-known member
Beiträge
107
Gemäß Beschreibung kann offenbar auch das DT-06 im STA-Modus arbeiten. Damit könnte ich also das DT-06 mit dem heimischen Router verbinden, außerdem noch den Computer mit dem heimischen Router, und dann hätte ich Internet und Mission Planner gleichzeitig, ja?

Was muss ich denn am DT-06 einstellen, damit das klappt?
 

Jenny

Well-known member
Beiträge
107
Hallo Reinhard,

nach vielen Tests hat es immer noch nicht geklappt. Da es Wichtigeres gibt, werde ich das mal hinten anstellen und eine Anleitung schreiben, wenn ich es später doch mal hin bekommen sollte.

Vielen Dank nochmal!
 

berny46

Well-known member
Beiträge
182
Da geht es dir wie mir ....
BT habe ich nicht hinbekommen.

Mit WiFi geht es einfacher.
 

Reinhard

Administrator
Teammitglied
Beiträge
312
Was klappt denn nicht? Voraussetzung ist erstmal, dass Du zum DT-06 im AP-Modus verbinden kannst. Wenn Du das DT-06 angeklemmt hast und Strom drauf gibst, müsste ein WLAN-AP auftauchen und zu dem verbindest Du Dich dann.

Wenn das geht, machst Du mal ein paar Screenshots von den aktuellen Einstellungen und stellst diese hier rein.
 

Jenny

Well-known member
Beiträge
107
Hallo Reinhard,

vielen Dank!

Ich habe die Screenshots hier eingestellt:

Ich nehme an, die Einstellung erfolgt bei "Station Settings" in den WiFi-Settings, ja?

Bei den WiFi-Settings kann ich bei "Station Settings" aus der SSID-Liste jede Menge lokale Router wählen, inklusive meinem. Soll dort unter "Password" der WPA-Schlüssel für den Router eingetragen werden? Oder muss dort ein Passwort für das DT-06 als Station vergeben werden?

Schöne Grüße
Jenny
 

Reinhard

Administrator
Teammitglied
Beiträge
312
Soll dort unter "Password" der WPA-Schlüssel für den Router eingetragen werden?
Genau.

Du darfst bei den Wifi-Settings nicht beide Optionen aktivieren. Entweder AP oder Station. Und beim SSID Namen lass die Sonderzeichen weg, schreib "ArduPilot" oder "Jenny" oder sonstwas einfaches.

In Beitrag #2 stehen ansonsten die richtigen Einstellungen.
 

Jenny

Well-known member
Beiträge
107
Mit meinem Router habe ich das DT-06 jetzt offenbar verbunden: "Doit-WiFi", mit der für das Modul korrekten MAC-Adresse wird im Router als "verbunden" angezeigt.

Wie kann ich denn jetzt mit Mission Planner eine Verbindung zu dem Modul bekommen?
 

Reinhard

Administrator
Teammitglied
Beiträge
312
In dem Du im MP oben rechts UDP anstatt einen Com-Port wählst und lt. Deinen Einstellungen mit Port 9000 verbindest. Das solltest Du aber noch ändern auf den Standard-Port 14550 wie vom MP vorgeschlagen. Deshalb der Hinweis auf Beitrag #2 ...

Bzw. vorher guckst Du noch mal, welche IP-Adresse Dein Router für das Modul vergeben hat.
 

Jenny

Well-known member
Beiträge
107
Du darfst bei den Wifi-Settings nicht beide Optionen aktivieren. Entweder AP oder Station. Und beim SSID Namen lass die Sonderzeichen weg, schreib "ArduPilot" oder "Jenny" oder sonstwas einfaches.

Mit den Sonderzeichen hatte ich mit WiFi-Geräten bisher noch keine Probleme, ich werde es aber ändern.

Wenn ich AP abschalte, dann komme ich aber nicht mehr ins Webinterface, falls etwas falsch eingestellt ist, oder doch? Beim "WiFi-Status" des Moduls steht jetzt übrigens auch "connected(rssi: -41)" da.
 

Reinhard

Administrator
Teammitglied
Beiträge
312
Wenn ich AP abschalte, dann komme ich aber nicht mehr ins Webinterface, falls etwas falsch eingestellt ist, oder doch?
Wenn eine Verbindung via Station existiert hast Du eine IP-Adresse und mit der kommst Du auch aufs Modul. Selbst habe ich allerdings nur mit AP getestet. Musste halt mal gucken, ob beides geht.
 

Jenny

Well-known member
Beiträge
107
Eine Verbindung als Station zu meinem Router habe ich jetzt offenbar, eine IP habe ich auch. Der Router erkennt das Ding.

Gleichzeitig habe ich es als AP zugänglich, und kann mit diesem wie gewohnt in Windows verbinden und es nötigenfalls umkonfigurieren. Es scheint also beides zu gehen, sicher bin ich aber noch nicht.

Wenn ich im Mission Planner UDP auswähle, dann fragt es doch nur nach dem Port, nicht aber nach der IP? Woher weiß Mission Planner dann, mit welcher IP es sich verbinden muss?
 

Reinhard

Administrator
Teammitglied
Beiträge
312
Weil das Modul ein Broadcast auf 192.168.x.255 macht ... Das "hören" dann alle von .1 bis .254.
 
Oben