Takeoff einrichten

Sven82

Well-known member
Beiträge
109
Ich hab mal eine Frage zum FlightMode Takeoff. Hab mir das auf einen freien Kanal gelegt und Takeoff wird dann unter "aktueller Modus" auch angezeigt. Wenn ich gearmed habe, müsste da nicht der Motor anlaufen? Test im Hobbykeller ohne GPS-Signal. Setzt es das GPS-Signal voraus?
 

Sven82

Well-known member
Beiträge
109
Ja, das hab ich :)

Takeoff zeigt es auch an im Arduplane sowie im Yaapu-Script, aber Motor läuft nicht an.
 

Sven82

Well-known member
Beiträge
109
Also der Motor läuft bei "armed" normal an. Hab ihn nochmal kalibriert, jedoch keine Veränderung. Zum Kalibieren muss ich im Sender aber wieder unter Servo auf 100% stellen, sonst lässt sich der Regler nicht anlernen.
 
Zuletzt bearbeitet:

Sven82

Well-known member
Beiträge
109
Wenn ich Takeoff ausführe, dann bewegen sich im Servo-Output auch die beiden Elevons ganz wenig, nur der Motor startet nicht.

Muss vielleicht etwas in den Parametern von Takeoff noch eingestellt werden? Mit TKOFF_THR_MAX 100 hab ich auch schon versucht.

Screenshot 2021-01-08 184023.png
 

Reinhard

Administrator
Teammitglied
Beiträge
440
Takeoff läuft normal ab, wenn eine Bewegung erkannt wird. Sprich, wenn der Flieger geworfen wird. Zum simulieren kannst Du den mal in beide Hände nehmen und kräftig nach vorn rucken. Props sind beim Test natürlich ab setze ich mal voraus ...

Selbst habe ich meist folgende Einstellungen:

TKOFF_ALT = 100m (ggfs. abhängig von den Örtlichkeiten)
TKOFF_DIST = 100m (dto.)

TKOFF_THR_MIN_ACC = 10 (m/s, "Ruckwert", die Geschwindigkeit der Vorwärtsbewegung)
TKOFF_THR_DELAY = 50 (5 Sekunden)
TKOFF_THR_SLEW = 50 (%/s = 2 Sekunden)

Die Prozedur läuft dann so ab: wenn TKOFF_THR_MIN_ACC erreicht ist (Flieger nach vorn rucken) läuft TKOFF_THR_DELAY ab und dann startet der Motor. TKOFF_THR_SLEW bestimmt die Zeit, bis TKOFF_THR_MAX erreicht ist. Letzterer Wert ist je nach Flieger unterschiedlich. Bspw. 70%.

In meinem Fall rucke ich also einfach den Flieger nach vorn (werf ihn aber noch nicht) und kann mich dann innerhalb 5 Sekunden auf den Motorlauf vorbereiten. Wenn der Motor anläuft wird geworfen.

Das Beispiel ist für einen Traktor-Antrieb mit 2 Motoren und relativ schwerem Flieger. Beim Pusher wirft man wohl erst und lässt dann nach einer gewissen Zeitspanne den Motor anlaufen.

Es gibt aber noch einige andere Parameter ... Fürs Maiden würde ich kein Takeoff nehmen, sondern wie beschrieben Armen, Gas geben und im FBWA Mode werfen. Zuviel Automatik am Anfang ist eher nicht so gut ...
 

Sven82

Well-known member
Beiträge
109
Alles klar danke, Takeoff soll nicht für den Erstflug sein. Erstflug starte ich dann in FBWA und dann weiter mit Autotune, wie bei dir in der Anleitung steht. :D

Wenn ich gewusst hätte, dass der FC so schlau ist und erst bei Bewegung startet, hätte ich mir die Programmierung in OpenTX sparen können. Da war auch geplant, nach Ansage mit Counter zu werfen und wenige Sekunden später den Motor zu starten, da ich annahm, mit Takeoff startet der Motor direkt los. Wieder was gelernt (y)
 

Heiner99

Active member
Beiträge
28
Versuche gerade an einem Flieger Autotakeoff einzurichten. Dabei ist mir aufgefallen, das das Höhenruder beim schalten in den Takeoff-modus nach unten geht. Also falsch. Im FBWA und auch in Stabilize geht alles richtig. Auch eingaben mit der Steuerrung sind richtig.
Dabei habe ich schon einige Flieger mit Auto Takeoff eingerichtet. Das hatte ich noch nie.
Wo liegt mein Denkfehler ??
 

Reinhard

Administrator
Teammitglied
Beiträge
440
Im FBWA und auch in Stabilize geht alles richtig.
Wenn nur der Flieger bewegt wird, ohne manuelle Eingabe?

Es müssen ja drei Dinge passen: in FBWA Flieger bewegen und die Ruder bewegen sich gegenläufig / in FBWA Ruder mit Knüppel bewegen / in MANUAL Ruder mit Knüppel bewegen.

Ich tippe darauf, dass der erste Punkt beim Höhenruder schon falsch läuft.
 

Heiner99

Active member
Beiträge
28
Ich hab,s noch mal getestet.
In Manualmodus Ich drücke den Stick und Höhenruder geht runter.
In FBWA Nase nach unten Höhenruder geht hoch.
Jetzt schalte ich Autotakeoff und das Höhenruder geht runter !!
Ich versteh das gerade nicht.
Ich werde mal einen anderen Fliegen nehmen, und die Daten vom TX und FC vergleichen. Da hat TKOFF prima geklappt.
 
Zuletzt bearbeitet:

Heiner99

Active member
Beiträge
28
Hallo Reinhard
Ich versuche gerade an meinem Wing mit Klapppropeller den Motoanlauf mit TKOFF_THR_SLEW etwas sanfter zu machen.
Egal ob ich da -1 oder 50 eintrage, da ändert sich nix. Kannst du mir da helfen ?
 

Reinhard

Administrator
Teammitglied
Beiträge
440
Bei -1 dreht der Motor sofort voll hoch. Bei 50 (%) dauert es 2 Sekunden bis der Motor hochgelaufen ist.

Wenn Du da keinen Unterschied hörst / siehst könnte es sein, dass der Motor nicht schneller beschleunigen kann.
 

Heiner99

Active member
Beiträge
28
Ich hätte gerne das der Motor langsamer anläuft, damit sich die Klappropeller besser entfallen können.
Bei mir läuft der Motor immer voll an. Bei mir ändert sich aber nix. Ich dachte, das vielleicht noch ein anderer Parameter zuständig ist.
 

Heiner99

Active member
Beiträge
28
4.1 letzte. .Aber schon vor 4 Wochen geladen.
Ich kann damit aber leben, muss nur dran denken das die Prop,s einigermaßen richtig stehen beim schalten nach Takeoff .
 
Oben Unten