Bad Gyro Health mit FC Kakute F7

Andi1957

Active member
Beiträge
30
Hallo, die gleiche Meldung erhalte ich aktuell auch bei einem Kakute F 7,den ich mit Arduplane betreibe. Er reagiert dann auf nichts. Wie ich im Netz gefunden und ausprobiert habe, passiert es bei mir, wenn ich den F7 zuerst per USB am PC anschließe. Wenn ich den F7 aber zuerst extern mit Strom versorgen und dann per USB anschließe, funktioniert er zumindest am PC richtig. Die Meldung erscheint dann nicht.

Gruß Andreas
 

Reinhard

Administrator
Teammitglied
Beiträge
404
Moin Andreas,

ich hab Deinen Beitrag in einen neuen Thread mit passendem Titel verschoben ...

Selbst habe ich ebenfalls ein Kakute F7 AIO im Einsatz. Wenn ich die FC nur via USB anschließe, kommen lediglich diese Meldungen:

KakuteF7 001B002B 34365107 31393931
ChibiOS: d443078c
ArduPlane V3.10.0-dev (3170327a)

und im HUD-Display wird ein "Bad Compass Health" angezeigt, was lediglich daran liegt, dass das GPS nur mit USB nicht bestromt wird und daher noch keine Richtungsinformationen vorliegen.

Häng am besten mal die aktuelle Parameterdatei hier an und kopiere auch die kompletten Meldungen.
 

Andi1957

Active member
Beiträge
30
Moin Reinhard, es ist in der Tat so, dass die Meldung kommt, wenn ich den F7 ohne externe Stromversorgung anschließe.... Aber nicht immer... Deshalb kann ich es mir auch nicht erklären. Habe dann mehrfach mal die Firmware gewechselt, mit dem gleichen Ergebnis. Schließe ich aber zuerst Akku an und dann USB, dann kommt die Meldung nicht. Bin ich aber nicht selbst drauf gekommen, sondern es scheint auch anderen so zu gehen, denn das habe ich so im Netz gefunden.
Gruß Andreas
 

Reinhard

Administrator
Teammitglied
Beiträge
404
Welche FC hast Du denn nun genau? Kakute F7 oder F7 AIO?
Welche Firmware hast Du geflashed? Latest, Stable, mit/ohne Bootloader?
Die Kalibration geht problemlos?
 

Andi1957

Active member
Beiträge
30
Ich habe den Kakute F7 mit der latest FW vom 09.07.. Die Parameter Einstellungen habe ich auf den Standardeinstellungen gelassen, da er im Moment nur zum "spielen" ist und nicht in ein Modell soll.
 

Reinhard

Administrator
Teammitglied
Beiträge
404
Dann würde ich erstmal ein wenig mehr mit der FC "spielen". Vermutlich ist das Problem keines mehr, wenn die FC konfiguriert und mit GPS & Co. verbunden wurde.
 

Andi1957

Active member
Beiträge
30
So - ich habe mal weiter "gespielt" und den Kakute F7 in einen 450er Heli eingebaut. Als GPS habe ich ein BN 880 mit Kompass angeklemmt.
Als Firmware ist die Arducopter-Heli V4.0.0-dev geflasht.
Das Ganze habe ich heute mehrfach auf unserem Platz geflogen und ich bin begeistert.
Der Heli fliegt sehr stabil - die Modi stabilize, acro und poshold funktionieren einwandfrei. Und völlig begeistert war ich von der RTL Funktion.
Ich habe den Heli ca 200m weggeflogen und auf poshold gestellt. Dann RTL geschaltet.
Der Heli gierte langsam um die Hochachse und richtete sich mit der Front zum Homepoint aus. Dann flog er langsam zurück zum Startplatz und drehte sich dort in die Startposition. Anschließend begann er mit der Landung und setzte weich direkt auf der Startfläche auf.
Besser hätte es für den / die ersten Versuche nicht laufen können.
Ich habe jetzt noch einen neuen Matek F765 wing hier liegen. Den werde ich wohl mal in einen 600er Heli einbauen, wenn es eine stabile Arducopter-Heli FW gibt.
 

Reinhard

Administrator
Teammitglied
Beiträge
404
Im Heli? Interessant, wusste ich noch gar nicht, dass das auch möglich ist. Bin aber zugegeben eigentlich nur im Flächen-Bereich aktiv.
 

Andi1957

Active member
Beiträge
30
Jap, ist die Einstellung für "Traditional Helicopter" im Ardupiloten. Gibt die FW extra als Arducopter-Heli auch für Doppelrotor / Tandemhelis.
Ein Fliegerfreund von mir ist ebenfalls am testen und will die Arducopter-Software in seinem 18 kg schweren Chinook Doppelrotor-Scaleheli nutzen.
So kann man im Flug entspannt Sonderfunktionen bedienen, ohne sich ausschließlich um den Flug zu kümmern.
Meine nächste Aufgabe ist es den Heli eine Mission fliegen zulassen - auch mit Autostart. Die Auto-Landung funktioniert ja gut, wie die RTL Funktion gezeigt hat.
 
Oben